It says "No internet connection detected" but the PC is connected to the internet

It says "No internet connection detected" but the PC is connected to the internet

Symptom:

This error appears when you launch the Hatch Embroidery software but the PC is still connected to the internet. 


Cause:

There can be two reasons to get this message:

1. Your virus checker program is blocking Hatch.

Be sure to have "Wilcom" in the exclusions folder of your virus checker program.

2. Recent Windows Update

It is caused by the recent Windows security update. Hatch Embroidery software can no longer support the older TLS 1.0 security of Microsoft Edge or later is required to be installed and updated.

Transport Layer Security (TLS) is a protocol that ensures privacy between communicating applications and their users on the internet. When a server and client communicate, TLS ensures that no third party may eavesdrop or tamper with any message. TLS is the successor to the Secure Sockets Layer (SSL).

In keeping with PCI DSS requirements, it is mandatory to upgrade from TLS 1.0 to TLS 1.1 or higher, before June 01, 2018.

The minimum version of supported browsers: 

  • Microsoft Edge or later

Solution:

Ensure that you install the latest Microsoft Edge browser with all updates. Microsoft Edge update settings - Microsoft Support

Once this is done, you should no longer have this problem.

Please note: Wilcom International is not responsible for any software installed or updated on your computer. It is always advisable to backup your data and follow best practices.